Thursday, October 1, 2015

InvalidSecurity : error in processing the WS-Security security header in SOA Suite 12c

Problem:

Even though the SOA composite does not have any WS security policies attached to it, we still get this error when invoking the service:
<env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/">   <env:Header>      <tracking:faultId xmlns:tracking="http://oracle.soa.tracking.core.TrackingProperty">20002</tracking:faultId>   </env:Header>   <env:Body>      <env:Fault xmlns:ns0="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd">         <faultcode>ns0:InvalidSecurity</faultcode>         <faultstring>InvalidSecurity : error in processing the WS-Security security header</faultstring>         <faultactor/>      </env:Fault>   </env:Body></env:Envelope>

Solution:

This error could be caused if your WSM and SOA applications are deployed to different managed servers, and the WSM managed server is not running.

1. Start up the WSM managed server (e.g., wsm_server1, wls_wsm1).


Applicable Versions:
  • Oracle SOA Suite 12c



1 comment:

madhu chilipi said...

Hi Ahmed,

I have single SOA_Server, I need to create wsm_server ?

while testing service i am getting this error.Checked with the composite polices are attached.



844446



ns0:InvalidSecurity
InvalidSecurity : error in processing the WS-Security security header






Thanks
Madhu