Wednesday, November 19, 2008

AIA 2.2 does not install on SOA Suite

When installing Oracle Application Integration Architecture (AIA) Foundation Pack 2.2.0 (or 2.2.1) on top of Oracle SOA Suite, you may encounter the following error:

This despite the fact that the Oracle AIA Installation documentation (Oracle Application Integration Architecture 2.2: Installation Guide - Release 2.2 - Part No. E12762-01) lists the following installation prerequisite:

  • Oracle SOA Suite 10g Release 3 ( or higher) (32 bit)
To work around this, install SOA Suite, upgrade to SOA Suite, and install AIA 2.2.0. At that point, you can either upgrade to AIA 2.2.1 or SOA Suite in any order.

So in conclusion:

  • AIA FP 2.2.0 and 2.2.1 are certified to run on Oracle SOA Suite 10g (
  • There is a bug in the AIA FP 2.2 installer in which it does not install on Oracle SOA Suite 10g (
  • To work around this, install AIA FP 2.2.0/2.2.1 on SOA Suite, then upgrade to


Ashwini said...

Hi Ahmed,

We had SOA Suite running,and AIA FP 2.2.1 running.
The SOA Suite was upgraded to
All the AIA Processes in the BPEL Console are throwing error now.

Should any post install step be carried out to resolve this.


Ahmed said...


In a recent project, we installed SOA Suite, upgraded to, then installed AIA FP 2.2.1 and it worked correctly.

Please contact me at aaboulnaga at itconvergence dot com. I need some more information from you. Hopefully we can get this resolved.