Saturday, February 12, 2011

Error starting up soa_server1 due to missing 'OracleSystemUser'

Problem:

We tried starting up our the 'soa_server1' on Oracle SOA Suite 11g, and the "soa_server1.out" log file showed the following error:
<Dec 23, 2010 8:15:03 PM EST> <Warning> <Deployer> <BEA-149078> <Stack trace for message 149004
weblogic.application.ModuleException: Exception preparing module: EJBModule(hw_services_wls_ejb.jar)

Unable to deploy EJB: ASNSInteraction from hw_services_wls_ejb.jar:
The run-as security principal, 'OracleSystemUser', chosen for the EJB 'ASNSInteraction(Application: soa-infra, EJBComponent: hw_services_wls_ejb.jar)' is not a valid user principal in the current security realm. Please specify a valid user principal for the EJB to use.

        at weblogic.ejb.container.deployer.EJBModule.prepare(EJBModule.java:467)
        at weblogic.application.internal.flow.ModuleListenerInvoker.prepare(ModuleListenerInvoker.java:199)
        at weblogic.application.internal.flow.DeploymentCallbackFlow$1.next(DeploymentCallbackFlow.java:507)
        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:41)
        at weblogic.application.internal.flow.DeploymentCallbackFlow.prepare(DeploymentCallbackFlow.java:149)
        Truncated. see log file for complete stacktrace

Solution:

This is directly attributed to the fact that the "OracleSystemUser" WebLogic account was not created (this was due to another issue that had occured on the server).

1. Log on to the WebLogic Console (e.g., http://server:port/console)

2. Create a new group "OracleSystemGroup"

3. Create a new account "OracleSystemUser"


Applicable Versions:
  • Oracle SOA Suite 11g (11.1.1.3)
  • Oracle WebLogic Server 11g (10.3.3)

Ahmed Aboulnaga

1 comment:

Buy Viagra online said...

Thanks for the post and the information, I was looking for the solution as I was experiencing the same inconvenience.